Scheduled for October 21, 2025 at 6:49 PM – 6:49 PM
Affects
Denmark: General Infrastructure
Under maintenance from 6:49 PM to 6:49 PM
In progress
October 21, 2025 at 6:49 PMIn progress
October 21, 2025 at 6:49 PMMaintenance is now in progress
Completed
October 21, 2025 at 6:49 PMCompleted
October 21, 2025 at 6:49 PM