Scheduled for June 27, 2025 at 7:00 AM – 3:00 PM
Affects
Denmark: General Infrastructure
Under maintenance from 7:00 AM to 3:00 PM
Completed
June 27, 2025 at 3:00 PMCompleted
June 27, 2025 at 3:00 PMMaintenance has completed successfully
Planned
June 27, 2025 at 7:00 AMPlanned
June 27, 2025 at 7:00 AMWe are activating new solar power generating capacity in the DK-DC1 today. The electricians do not expect any disruption of power or think that we need to do any sort of emergency power testing today, so no disruption is expected.
In progress
June 26, 2025 at 7:15 AMIn progress
June 26, 2025 at 7:15 AMMaintenance is now in progress.